const regex = /^(\[(?<title>[^\]]*)?\]\((?<link>[A-Za-z0-9\:\/\.\- ]+)(?<description>\"(.+)\")?\))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\[(?<title>[^\\]]*)?\\]\\((?<link>[A-Za-z0-9\\:\\\/\\.\\- ]+)(?<description>\\"(.+)\\")?\\))', '')
const str = `[test](http://google.com "hello")
[test](https://google.com "hello")
[test](google.com)
[](google.com)
[test](google.com "hello")
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}