re = /(\w+)\s*\{([^({]+)\s*[({](.*)/m
str = '{"querys":"query{secondstring(input:{
{"query":"query{helloworld {sdsd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end