re = /(?:(.*)?((?:\/\/.*|--.*|\/\*.*\*\/))(.*))/
str = 'joragjlbjugf /*bfdf*/ ugefwjds
bfjksbdb //ndsnvdlv
ebfdbsdj --bjkdsbdbj'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end