import re
regex = re.compile(r".*?(?=the)", flags=re.UNICODE | re.IGNORECASE)
test_str = "this is completely customizable through the dashboard. This is a separate area from the main c"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")