import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(((?>[^()]|(?R))*)\\)";
final String string = "x= coord(:,1);\n"
+ "y= coord(:,2);\n\n"
+ "natG_coord(1,1)= sqrt(1/3);\n"
+ "natG_coord(2,1)= -sqrt(1/3);\n"
+ "natG_coord(3,1)= -sqrt(1/3);\n"
+ "natG_coord(4,1)= sqrt(1/3);\n\n"
+ "for i=1:4\n"
+ " dNG(1,i)= (1+etaG(i))/4 + csiG(i)*(1+etaG(i))/2 - (1-etaG(i)^2)/4 - 2*csiG(i)*(1-etaG(i)^2)/4;\n"
+ " dNG(2,i)= -(1+etaG(i))/4 + csiG(i)*(1+etaG(i))/2 + (1-etaG(i)^2)/4 - 2*csiG(i)*(1-etaG(i)^2)/4;\n"
+ " dNG(3,i)= -(1-etaG(i))/4 + csiG(i)*(1-etaG(i))/2 + (1-etaG(i)^2)/4 - 2*csiG(i)*(1-etaG(i)^2)/4;\n"
+ " dNG(4,i)= (1-etaG(i))/4 + csiG(i)*(1-etaG(i))/2 - (1-etaG(i)^2)/4 - 2*csiG(i)*(1-etaG(i)^2)/4;\n"
+ "end";
final String subst = "[$1]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}