$re = '/(--extra-vars\s)([a-zA-Z0-9\=\s]*)\s/';
$str = '--extra-vars user=zaslam a=abcd --test';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);