$re = '/\<b[^<]*?\>([^\s<]+?)\<\/b\>\s*(?!\<br\>)/iu';
$str = 'should NOT match - this is the problem
<b>word</b> <br>
should match
<b>word</b> in text
half<b>word</b>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);