const regex = /(?:^\s*Some.*(?:thing\.|stuff\.)\s*^\s*Some)|(^\s*Some)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^\\s*Some.*(?:thing\\.|stuff\\.)\\s*^\\s*Some)|(^\\s*Some)', 'gm')
const str = `Some thing.
Some other text.
Some line.
Some additional text.
Some stuff.
Some additional text.
Some additional text.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}