$re = '/(?!path1\/path2)/';
$str = 'path1/path2';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);