re = /^.*?\S.*(?=\n\n)/m
str = 'This is some text
This is some text
This is some text
This is some text
This is some text
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end