re = /^(?=[^a]*a[^a]*$)(?=[^b]*b[^b]*$)(?=[^c]*c[^c]*$)(?=[^d]*d[^d]*$).*/m
str = 'abcd
bcad
abbd
abcdd
abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end