$re = '/^[ ]?\w+(?:[ ]\w+)?$/m';
$str = 'Silver silver
1 min
Silver
min';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);