package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*(?|"([^"]*)"|([^,]+))\s*,?`)
var str = `"C:\name, name, name\",222,45,8,18,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}