$re = '/[a-zA-Z]+=(\w+{*(?:[a-zA-Z]+=*[\w=,]*)?}*),*/m';
$str = 'Objet[id=100,name=car,type=grey,source=sourceId{id=12,version=12},linked=true]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);