package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\b[A-Z]\w*\s*)+$`)
var str = `Foo bar
Foo Bar
Foo Bar Foobar`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}