import Foundation
let pattern = #"(?:(?<tag>(?<!\/).)|(?:\/.))(?: href="(?<url>.+?)")?>(?<text>.+?)<"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<p>The <a href="https://www.legislation.gov.uk/ukpga/2010/23/contents">UK Bribery Act</a> (“the Act”) received Royal Assent in April 2010 and came into force in July 2011. It was designed to modernise and simplify the UK’s anti-corruption legislation and to more effectively address requirements imposed under the <a href="http://www.oecd.org/daf/anti-bribery/ConvCombatBribery_ENG.pdf">OECD anti-bribery Convention</a>. The Act outlined four prime offences, including the introduction of a new corporate offence of failure to prevent bribery. And the <b>rest is history</b> so is the ending.</p>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)