$re = '/([a-zA-Z]+)(, )(\d{1,2})( )([a-zA-Z]+)/';
$str = 'Friday, 3 October';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);