re = /^(?!.*(?=(.))((.{9})+|(.(?!(?3)*$))+|(?(?=.(...)*$)(.(?!(.{27})*$)){7}|.)+)\1)/
str = '978531264436729518152684937895263471724918653361475892687392145519847326243156789'
# Print the match result
str.match(re) do |match|
puts match.to_s
end