re = /^[^(]+(?=\()|(?<=[(,])\s*\K(?:<.*?>|.*?)(?=[,)])/m
str = 'anim(10, <-0.016, -0.006, 0.217>, <0.000, 0.000, 0.707, 0.707>, <0.016, 0.010, 0.012>)
texture(-1, -1, 80c4c40e-4e59-f6db-4a3f-e2a82d1ebcc0, <1,1,1>, <0,0,0>, 0, foo())'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end