# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?!&\w{1,8};)&"
test_str = ("<a href=\"http://www.testassociation.com/test.html?ab=5&compac=3&cd=5&ab=c\" target=\"_blank\">Customer Association</a>&\n"
""\n"
"&\n"
"'\n"
"<\n"
">\n"
" \n"
"¡\n"
"¢\n"
"£\n"
"¤\n"
"¥\n"
"¦\n"
"§\n"
"¨\n"
"©\n"
"ª\n"
"«\n"
"¬\n"
"­\n"
"®\n"
"¯\n"
"°\n"
"±\n"
"²\n"
"³\n"
"´\n"
"µ\n"
"¶\n"
"·\n"
"¸\n"
"¹\n"
"º\n"
"»\n"
"¼\n"
"½\n"
"¾\n"
"¿\n"
"À\n"
"Á\n"
"Â\n"
"Ã\n"
"Ä\n"
"Å\n"
"Æ\n"
"Ç\n"
"È\n"
"É\n"
"Ê\n"
"Ë\n"
"Ì\n"
"Í\n"
"Î\n"
"Ï\n"
"Ð\n"
"Ñ\n"
"Ò\n"
"Ó\n"
"Ô\n"
"Õ\n"
"Ö\n"
"×\n"
"Ø\n"
"Ù\n"
"Ú\n"
"Û\n"
"Ü\n"
"Ý\n"
"Þ\n"
"ß\n"
"à\n"
"á\n"
"â\n"
"ã\n"
"ä\n"
"å\n"
"æ\n"
"ç\n"
"è\n"
"é\n"
"ê\n"
"ë\n"
"ì\n"
"í\n"
"î\n"
"ï\n"
"ð\n"
"ñ\n"
"ò\n"
"ó\n"
"ô\n"
"õ\n"
"ö\n"
"÷\n"
"ø\n"
"ù\n"
"ú\n"
"û\n"
"ü\n"
"ý\n"
"þ\n"
"ÿ\n"
"Œ\n"
"œ\n"
"Š\n"
"š\n"
"Ÿ\n"
"ƒ\n"
"ˆ\n"
"˜\n"
"Α\n"
"Β\n"
"Γ\n"
"Δ\n"
"Ε\n"
"Ζ\n"
"Η\n"
"Θ\n"
"Ι\n"
"Κ\n"
"Λ\n"
"Μ\n"
"Ν\n"
"Ξ\n"
"Ο\n"
"Π\n"
"Ρ\n"
"Σ\n"
"Τ\n"
"Υ\n"
"Φ\n"
"Χ\n"
"Ψ\n"
"Ω\n"
"α\n"
"β\n"
"γ\n"
"δ\n"
"ε\n"
"ζ\n"
"η\n"
"θ\n"
"ι\n"
"κ\n"
"λ\n"
"μ\n"
"ν\n"
"ξ\n"
"ο\n"
"π\n"
"ρ\n"
"ς\n"
"σ\n"
"τ\n"
"υ\n"
"φ\n"
"χ\n"
"ψ\n"
"ω\n"
"ϑ\n"
"ϒ\n"
"ϖ\n"
" \n"
" \n"
" \n"
"‌\n"
"‍\n"
"‎\n"
"‏\n"
"–\n"
"—\n"
"‘\n"
"’\n"
"‚\n"
"“\n"
"”\n"
"„\n"
"†\n"
"‡\n"
"•\n"
"…\n"
"‰\n"
"′\n"
"″\n"
"‹\n"
"›\n"
"‾\n"
"⁄\n"
"€\n"
"ℑ\n"
"℘\n"
"ℜ\n"
"™\n"
"ℵ\n"
"←\n"
"↑\n"
"→\n"
"↓\n"
"↔\n"
"↵\n"
"⇐\n"
"⇑\n"
"⇒\n"
"⇓\n"
"⇔\n"
"∀\n"
"∂\n"
"∃\n"
"∅\n"
"∇\n"
"∈\n"
"∉\n"
"∋\n"
"∏\n"
"∑\n"
"−\n"
"∗\n"
"√\n"
"∝\n"
"∞\n"
"∠\n"
"∧\n"
"∨\n"
"∩\n"
"∪\n"
"∫\n"
"∴\n"
"∼\n"
"≅\n"
"≈\n"
"≠\n"
"≡\n"
"≤\n"
"≥\n"
"⊂\n"
"⊃\n"
"⊄\n"
"⊆\n"
"⊇\n"
"⊕\n"
"⊗\n"
"⊥\n"
"⋅\n"
"⋮\n"
"⌈\n"
"⌉\n"
"⌊\n"
"⌋\n"
"⟨\n"
"⟩\n"
"◊\n"
"♠\n"
"♣\n"
"♥\n"
"♦\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.