const regex = /^(?P<Name>\w+)\s-\s(?P<goalscorer>.+)\s\((?P<assist1>.+),\s(?P<assist2>.+)\)\s?$|\)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?P<Name>\\w+)\\s-\\s(?P<goalscorer>.+)\\s\\((?P<assist1>.+),\\s(?P<assist2>.+)\\)\\s?$|\\)', '')
const str = `CHI - J.Toews (H.Sedin, D.Sedin) `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}