const regex = /(?=Ob)(?:(\w+=)([\w\s]+,?))+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=Ob)(?:(\\w+=)([\\w\\s]+,?))+', 'g')
const str = `Ob=Web technology,OB=Product SPe,OB=Dev profile,OB=Computer Management,oB=Hardware Services,cd=sti,CD=com,cd=ws`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}