use strict;
my $str = 'https://www.google.co.uk/webhp?sourceid=chrome-instant&ion=1&espv=2&ie=UTF-8#q=wordpress+redirect+get+referrer
mysite.co.uk
http://mysite.co.uk
mysite.ie
http://mysite-wp.sandbox/wp-admin/tools.php?page=redirection.php
http://superuser.com/questions/231540/how-can-i-see-a-pages-referrer-in-chrome
https://regex101.com/#pcre';
my $regex = qr/^((?!mysite|google).)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}