$re = '/.*(?=\d{2}\.\d{2})/';
$str = 'DuraFlexHose Water 1/2" hex 300mm 30.00';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);