$re = '/,(?![^(]*\\\\)/';
$str = 'select distinct \\n(\'<a href=ORG_S.htm?keyno=\'+rtrim(ent.entid)+\' target=_blank id=\\"\'+rtrim(ent.mdsstring)+\'\\" name=\\"\'+rtrim(ent.entid)+\'\\" class=\\"vieworgglobal\\">\'+rtrim(ent.custno)+\' - \'+rtrim(ent.company)+\'</a>\') as customer, ent.phone, 0 as curr,\\n\\n(select SUM(billmast.balance) as balance from billmast where billmast.billid = ent.entid and ent.cid = \'abis\' and billmast.balance<>0 and billmast.invdate>dateadd(day,-60, getdate()) and billmast.invdate<dateadd(day,-30, getdate())\\n) as first,\\n\\n(select SUM(billmast.balance) as balance from billmast where billmast.billid = ent.entid and ent.cid = \'abis\' and billmast.balance<>0 and billmast.invdate>dateadd(day,-90, getdate()) and billmast.invdate<dateadd(day,-60, getdate())\\n) as second,\\n\\n(select SUM(billmast.balance) as balance from billmast where billmast.billid = ent.entid and ent.cid = \'abis\' and billmast.balance<>0 and billmast.invdate>dateadd(day,-120, getdate()) and billmast.invdate<dateadd(day,-90, getdate())\\n) as third,\\n\\n(select SUM(billmast.balance) as balance from billmast where billmast.billid = ent.entid and ent.cid = \'abis\' and billmast.balance<>0 and billmast.adddate<dateadd(day,-120, getdate())\\n) as fourth, \\n\\n(select SUM(billmast.balance) as balance from billmast where billmast.billid = ent.entid and ent.cid = \'abis\' and billmast.balance<>0 and billmast.invdate<dateadd(day,-30, getdate())) as total, \'1691\' as link\\n\\nfrom billmast,ent where billmast.billid = ent.entid and ent.cid = \'abis\' and billmast.balance<>0 and billmast.invdate<dateadd(day,-30, getdate()) order by customer';
$subst = ";";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;