import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![^ ])\\d(?!\\d)";
final String string = "id: N group: 1 category: NAMES : Mike\n"
+ "id: N group: 2 category: NAMES : Seth\n"
+ "id: # group: 1 category: PHONE : 123-456-789\n"
+ "id: # group: 2 category: PHONE : 111 111-1111\n"
+ "id: @ group: 1 category: EMAIL : mike@mail.com\n"
+ "id: @ group: 2 category: EMAIL : seth@yahoo.com";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}