#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?iy)^[\+\-]?((\d+)|(\d+\.\d+)|(\.\d+)|(\d+\.))(e[\+\-]?\d+)?$"
Local $sString = "-123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")