$re = '/\"([^\"]+?)\",?|([^,]+),?|,/';
$str = '発注先会社ID,EDI使用フラグ,発注先,メーカー名,注番,ステータス,伝票番号,品名,形式・材質,仕様・寸法,関連規格,図番,品番,手順No,作業明細,加工区分1,加工区分2,製番,手配№,合番,製番名,要求元依頼日,納期,要求元手配数,発注日,発注数,受入日,受入数,検収日,検収数,検査日,発注残,調達区分コード,調達,マル特,マル特文字,社内・社外,社内・社外文字,資材担当者emp_id,担当者,要求元emp_id,要求元,要求元5桁コード,要求元dept_id,要求元部署,回答日,メモ情報,単価,材料単価,外注単価,合計単価,合計金額,差額,準備AH,加工AH,AH計,準備SH,加工SH,SH計,統計コード,上位品名,上位形式,上位図番,上位品番,製番ID,製作分類,差戻し理由,回答更新日, 工程管理担当者,要求元3桁コード
"2931","使用しない","(株)シースター・コーポレーショ","東海カ-ボン","235111693","未納:","","カーボンブラシ","MCG-6SD","MD-64B・寸法9*19*35","","A1428-35D*H","3814131405","0","","","","1000-00010","0","","ATS車上装置 車上子組立 リード線2.5m付","2022/04/28","2023/04/25","2","2023/04/25","38","","0","","0","","38","16","P","0","","0","内","672","K糸永 香太(55097)","672","K糸永 香太(55097)","55097","298","資)座間業務課","","","10","0","0","10","380","0","0","0","0","0","0","0","1-890","","","","","300964","304","","-","-","558",
"22800","使用しない","株式会社コスモ","","235111797","未納:変更","H23050000009","test product","","","","","C190702360","0","","","","22447009-02","0","","","2023/02/02","2024/04/01","150","2023/05/19","150","","0","","0","","150","4","P","","","","","718","K岡村 一隆(56245)","1133","K武富 裕司(64790)","","94","信・製)連動課","","","1,234","0","0","1,234","185,100","0","0","0","0","0","0","0","1-320","","","","","597612","123","","-","-","443",
"3152","使用する","株式会社日本サーキット","","235111800","未納:変更","H23050000019","TEST"," "," ","","*EST---TEST--TEST","C940301303","0","","","","80004001-02","0",""," ","2023/05/11","2023/10/10","1","2023/05/25","1","","0","","0","","1","4","P","","","","","718","K岡村 一隆(56245)","728","K加賀 誠剛(56355)","","94","信・製)連動課","","","15,251","0","0","15,251","15,251","251","0","0","0","0","0","0","1-500","","","","","597851","480","","-","-","443",
"11027","使用しない","三和電化株式会社","","216696600","完納:","H12060017153","","","","","","","0","AMP-DEH2-DV-(QR) デバイス取付
","AMP-DEH2-DV-(QR) デバイス取付","","9002-66330","0","","半導体製造装置向けRFシステムの製品化","2012/06/22","2912/06/30","6","2012/06/26","6","2012/06/28","6","2012/06/28","6","","0","16","P","0","","0","内","718","K岡村 一隆(56245)","2979","K横山 聡一(73147)","73147","310","PE・開)RF開発","","","700","0","0","700","4,200","0","0","0","0","0","0","0","6-630","","","","","382275","0","","-","-","790",
"3332","使用しない","株式会社ライテック","","235111833","未納:","H23060000002","","","","","","","0","","TEST","","8003-41250","0","","動作確認20230606","2023/06/06","2023/06/06","10","2023/06/06","10","","0","","0","","10","14","G","0","","0","内","693","K長谷川 剛(55958)","693","K長谷川 剛(55958)","55958","27","資)購買課","","","0","1,000","600","1,600","16,000","0","0","0","0","0","0","0","1-500","","","","","597932","0","","-","-","551",
"3131","使用しない","株式会社日新製作所","","201457873","完納:","H08050012404","","","","","","","0","試験用治具(模擬負荷抵抗取り付け板) 品管酢屋様依頼","試験用治具(模擬負荷抵抗取り付け板)","単価2600円","8004-41160","0","","C-ATS地上装置(機器室集中タイプ)","2008/05/19","2080/06/02","20","2008/05/19","20","2008/05/30","20","2008/05/30","20","2008/06/09","0","16","P","0","","0","内","1133","K武富 裕司(64790)","755","K酢屋 帝淳(57244)","57244","105","信・品)ATC","","","2,600","0","0","2,600","52,000","0","0","0","0","0","0","0","1-560","","","","","63152","0","","-","-","458",
"2931","使用しない","(株)シースター・コーポレーショ","","235111829","未納:","H23060000001","","","","","","","0","","TEST","","8003-41250","0","","動作確認20230606","2023/06/06","2023/06/06","10","2023/06/06","10","","0","","0","","10","14","G","0","","0","内","693","K長谷川 剛(55958)","693","K長谷川 剛(55958)","55958","27","資)購買課","","","0","1,000","600","1,600","16,000","0","0","0","0","0","0","0","1-500","","","","","597932","0","","-","-","551",
"2918","使用する","新光商事株式会社","","235111570","未納:","H21100000001","","","","","","","0","","","","","0","50111444","","2021/10/01","2024/09/30","1","2023/05/19","1","","0","","0","","1","14","G","","","","","718","K岡村 一隆(56245)","645","K宮内 恵(54496)","54496","228","信・生)第2G","","test memo","0","1,234","12,345","13,579","13,579","0","0","1","1","0","0","0","1-760","","","","","0","0","","-","-","480",
"2884","使用する","サンワテクノス株式会社","","235107820","未納:","H23050000012","20181129_2-2","","","","NA10231AB002A01","C181100108","1","","","","21996009-02","1","","","2019/06/20","2023/06/20","225","2023/05/25","225","","0","","0","","225","10","G","","","","","718","K岡村 一隆(56245)","680","K名和 俊夫(55259)","47209","228","信・生)第2G","","","0","10","123","133","29,925","0","0","0","0","2","2","452","1-610","","","","","583576","0","","-","K坂本 誠(59307)","480",
"2958","使用する","スリオジャパン株式会社","スリオジャパン","223207107","完納:","H14030007179","プラグ","MSG59P-L21"," ","シNO.VS000009","","S991216183","0","東京メトロ","","","8003-31850","2","","副都心線ホーム柵システム 東新宿駅情報伝送装置","2014/03/06","2104/05/20","3","2014/03/06","3","2014/05/20","3","2014/05/20","3","2014/05/20","0","4","P","","","","","2992","K成田 愛音(73273)","559","K古舘 宏明(52061)","445D1","479","信・製)工程管理","2014/05/20","","2,790","0","0","2,790","8,370","0","0","0","0","0","0","0","1-230","","","","","440420","0","","-","K飯野 将史(69708)","445",
"9028","使用しない","株式会社戸塚電子工業","(株)戸塚電子工業","232267913","完納:","H17020012567","PLS-DIFF2-QR購入仕様書","PLS-DIFF2-QR基板アッセンブル","共晶半田(有鉛)","UL","KR10775AA640B","C111207982","0","","","","5006-78040","2","","TML様向け3.2MHz-8.5kW ジェネレータ","2017/02/16","2027/02/20","1","2017/02/16","1","2017/04/21","1","2017/04/21","1","","0","4","P","","","","","718","K岡村 一隆(56245)","797","K牧野 久(58159)","8","231","PE・生)生産管理","",""納品済み同一製番のMCU-VTF改造に使用
"
","6,520","0","0","6,520","6,520","800","0","0","0","0","0","0","6-630","","","","","536883","0","","-","-","701",
"2729","使用する","株式会社ウエノ","サンワサプライ","223642632","完納:","H14040015606","SATA3ケーブル(0.5m)","TK-SATA3-05","ケーブル長0.5m、ラッチ付き","","","C140203312","0","","","","8002-44270","8","","マカオLRT【予備品】","2014/04/15","2914/06/18","2","2014/04/15","2","2014/06/18","2","2014/06/18","2","2014/06/19","0","4","P","","","","","1319","K鈴木 幸雄(52951)","3005","K三好 洸聖(73406)","445B","479","信・製)工程管理","2014/06/18","","990","0","0","990","1,980","68","0","0","0","0","0","0","1-460","","","","","404843","0","","-","K成清 正(58379)","445",
"2730","使用する","有限会社エンシュー製作所","","235104898","未納:変更(印刷待ち)","H23050000015","M-15190","","","","MA10263AA500","C190300578","0","","","","6009-15240","0","","Seiban for testing","2019/05/03","2023/06/16","1,000","2023/05/25","1,000","","0","","0","","1,000","16","P","0","","0","内","718","K岡村 一隆(56245)","1319","K鈴木 幸雄(52951)","52951","27","資)購買課","","","13","0","0","13","13,000","2,000","0","0","0","0","0","0","6-610","","","","","583589","0","","-","-","551",
"11359","使用しない","セーチョー工業株式会社","セ-チョ-工業","280166380","完納:","28016638000 ","コネクタカバー","SKR-009"," ","シNO.VS060363","","C050705591","0","","","","8007-65610","0","19200000","京王 次世代転てつ機予備品(右据付)","2007/11/19","2770/11/29","1","2007/11/19","1","2007/11/30","1","2007/11/30","1","","0","4","P","","","","","581","K川﨑 博紀(52919)","1782","K多賀谷 浩(kkin-tagaya)","9","240","京三金属","","","650","0","0","650","650","0","0","0","0","0","0","0","1-510","","","","","194774","0","","-","-","441",
"0","使用しない","","","235111852","未処理","","動作確認20210910_S材通常","","","","","C210900070","0","","","","40068007-03","0","","","2023/06/06","2023/06/01","100","","0","","0","","0","","0","4","P","","","","","1430","K三根 孝行(66934)","728","K加賀 誠剛(56355)","","94","信・製)連動課","","","0","0","0","0","0","0","0","0","0","0","0","0","","","","","","597934","0","","-","-","443",
"0","使用しない","","","235111848","未処理","","動作確認20210910_S材通常","","","","","C210900070","0","","","","40068007-02","0","","","2023/06/06","2023/06/01","100","","0","","0","","0","","0","4","P","","","","","1430","K三根 孝行(66934)","728","K加賀 誠剛(56355)","","94","信・製)連動課","","","0","0","0","0","0","0","0","0","0","0","0","0","","","","","","597933","0","","-","-","443",
"0","使用しない","","","235111814","未処理","","動作確認20220701_1","","","","","C220700018","0","","","","70243008-04","0","","","2023/05/29","2023/05/29","30","","0","","0","","0","","0","4","P","","","","","434","K德武 美代子(47843)","728","K加賀 誠剛(56355)","","94","信・製)連動課","","","0","0","0","0","0","0","0","0","0","0","0","0","","","","","","597921","0","","-","-","443",
"0","使用しない","","","235111814","未処理","","動作確認20220701_1","","","","","C220700018","0","","","","70243008-04","0","","","2023/05/29","2023/05/29","30","","0","","0","","0","","0","4","P","","","","","598","K小鞠 芳恵(53277)","728","K加賀 誠剛(56355)","","94","信・製)連動課","","","0","0","0","0","0","0","0","0","0","0","0","0","","","","","","597921","0","","-","-","443",
"0","使用しない","","","235111814","未処理","","動作確認20220701_1","","","","","C220700018","0","","","","70243008-04","0","","","2023/05/29","2023/05/29","30","","0","","0","","0","","0","4","P","","","","","581","K川﨑 博紀(52919)","728","K加賀 誠剛(56355)","","94","信・製)連動課","","","0","0","0","0","0","0","0","0","0","0","0","0","","","","","","597921","0","","-","-","443",
"0","使用しない","","","235111814","未処理","","動作確認20220701_1","","","","","C220700018","0","","","","70243008-04","0","","","2023/05/29","2023/05/29","30","","0","","0","","0","","0","4","P","","","","","635","K内山 敬介(54331)","728","K加賀 誠剛(56355)","","94","信・製)連動課","","","0","0","0","0","0","0","0","0","0","0","0","0","","","","","","597921","0","","-","-","443",
"0","使用しない","","","235111814","未処理","","動作確認20220701_1","","","","","C220700018","0","","","","70243008-04","0","","","2023/05/29","2023/05/29","30","","0","","0","","0","","0","4","P","","","","","652","K梅村 成(54849)","728","K加賀 誠剛(56355)","","94","信・製)連動課","","","0","0","0","0","0","0","0","0","0","0","0","0","","","","","","597921","0","","-","-","443",
"0","使用しない","","","235111814","未処理","","動作確認20220701_1","","","","","C220700018","0","","","","70243008-04","0","","","2023/05/29","2023/05/29","30","","0","","0","","0","","0","4","P","","","","","672","K糸永 香太(55097)","728","K加賀 誠剛(56355)","","94","信・製)連動課","","","0","0","0","0","0","0","0","0","0","0","0","0","","","","","","597921","0","","-","-","443",
"0","使用しない","","","235111814","未処理","","動作確認20220701_1","","","","","C220700018","0","","","","70243008-04","0","","","2023/05/29","2023/05/29","30","","0","","0","","0","","0","4","P","","","","","685","K帯津 貴子(55466)","728","K加賀 誠剛(56355)","","94","信・製)連動課","","","0","0","0","0","0","0","0","0","0","0","0","0","","","","","","597921","0","","-","-","443",
"0","使用しない","","","235111814","未処理","","動作確認20220701_1","","","","","C220700018","0","","","","70243008-04","0","","","2023/05/29","2023/05/29","30","","0","","0","","0","","0","4","P","","","","","693","K長谷川 剛(55958)","728","K加賀 誠剛(56355)","","94","信・製)連動課","","","0","0","0","0","0","0","0","0","0","0","0","0","","","","","","597921","0","","-","-","443",
"0","使用しない","","","235111814","未処理","","動作確認20220701_1","","","","","C220700018","0","","","","70243008-04","0","","","2023/05/29","2023/05/29","30","","0","","0","","0","","0","4","P","","","","","718","K岡村 一隆(56245)","728","K加賀 誠剛(56355)","","94","信・製)連動課","","","0","0","0","0","0","0","0","0","0","0","0","0","","","","","","597921","0","","-","-","443",
"0","使用しない","","","235111814","未処理","","動作確認20220701_1","","","","","C220700018","0","","","","70243008-04","0","","","2023/05/29","2023/05/29","30","","0","","0","","0","","0","4","P","","","","","3657","K大園 健介(76652)","728","K加賀 誠剛(56355)","","94","信・製)連動課","","","0","0","0","0","0","0","0","0","0","0","0","0","","","","","","597921","0","","-","-","443",
"0","使用しない","","","235111814","未処理","","動作確認20220701_1","","","","","C220700018","0","","","","70243008-04","0","","","2023/05/29","2023/05/29","30","","0","","0","","0","","0","4","P","","","","","2986","K熊坂 実千(73215)","728","K加賀 誠剛(56355)","","94","信・製)連動課","","","0","0","0","0","0","0","0","0","0","0","0","0","","","","","","597921","0","","-","-","443",
"0","使用しない","","","235111814","未処理","","動作確認20220701_1","","","","","C220700018","0","","","","70243008-04","0","","","2023/05/29","2023/05/29","30","","0","","0","","0","","0","4","P","","","","","1624","K原 智史(67658)","728","K加賀 誠剛(56355)","","94","信・製)連動課","","","0","0","0","0","0","0","0","0","0","0","0","0","","","","","","597921","0","","-","-","443",
"0","使用しない","","","235111814","未処理","","動作確認20220701_1","","","","","C220700018","0","","","","70243008-04","0","","","2023/05/29","2023/05/29","30","","0","","0","","0","","0","4","P","","","","","898","K藤代 慎二(60558)","728","K加賀 誠剛(56355)","","94","信・製)連動課","","","0","0","0","0","0","0","0","0","0","0","0","0","","","","","","597921","0","","-","-","443",
"0","使用しない","","","235111814","未処理","","動作確認20220701_1","","","","","C220700018","0","","","","70243008-04","0","","","2023/05/29","2023/05/29","30","","0","","0","","0","","0","4","P","","","","","848","K清水 完(59297)","728","K加賀 誠剛(56355)","","94","信・製)連動課","","","0","0","0","0","0","0","0","0","0","0","0","0","","","","","","597921","0","","-","-","443",
"0","使用しない","","","235111814","未処理","","動作確認20220701_1","","","","","C220700018","0","","","","70243008-04","0","","","2023/05/29","2023/05/29","30","","0","","0","","0","","0","4","P","","","","","816","K伊勢 周治(58395)","728","K加賀 誠剛(56355)","","94","信・製)連動課","","","0","0","0","0","0","0","0","0","0","0","0","0","","","","","","597921","0","","-","-","443",
"3345","使用しない","京三エンジニアリングサービス株式","","202994428","差戻し","","","","","","","","0","309-0499 20.75H","309-0499","20.75H","8007-32690","0","","C-ATS地上装置:SAユニット用S-ROM交換","2008/10/01","2200/09/30","1","","0","","0","","0","","0","14","G","","","","","581","K川﨑 博紀(52919)","1793","U大久保 友子(kes-ookubo)","","105","信・品)ATC","","","0","0","0","0","0","0","0","0","0","0","0","0","","","","","","182274","0","確認願います。","-","-","458",
"3345","使用しない","京三エンジニアリングサービス株式","","202994428","差戻し","","","","","","","","0","309-0499 20.75H","309-0499","20.75H","8007-32690","0","","C-ATS地上装置:SAユニット用S-ROM交換","2008/10/01","2200/09/30","1","","0","","0","","0","","0","14","G","","","","","685","K帯津 貴子(55466)","1793","U大久保 友子(kes-ookubo)","","105","信・品)ATC","","","0","0","0","0","0","0","0","0","0","0","0","0","","","","","","182274","0","確認願います。","-","-","458",
"3345","使用しない","京三エンジニアリングサービス株式","","202638146","差戻し","","","","","","","","0","308-1149 0H","308-1149","0H","8007-41530","0","","ATC化(連動-15) 踏切制御装置・連動IF装置:めじろ台機器室(高尾線)","2008/08/29","8007/08/29","1","","0","","0","","0","","0","14","G","","","","","685","K帯津 貴子(55466)","1793","U大久保 友子(kes-ookubo)","","102","信・品)連動","","","0","0","0","0","0","0","0","0","0","0","0","0","","","","","","193270","0","注番202643814にて検収済の為差戻します。","-","-","457",
"3345","使用しない","京三エンジニアリングサービス株式","","202638146","差戻し","","","","","","","","0","308-1149 0H","308-1149","0H","8007-41530","0","","ATC化(連動-15) 踏切制御装置・連動IF装置:めじろ台機器室(高尾線)","2008/08/29","8007/08/29","1","","0","","0","","0","","0","14","G","","","","","581","K川﨑 博紀(52919)","1793","U大久保 友子(kes-ookubo)","","102","信・品)連動","","","0","0","0","0","0","0","0","0","0","0","0","0","","","","","","193270","0","注番202643814にて検収済の為差戻します。","-","-","457",
"3345","使用しない","京三エンジニアリングサービス株式","","202208007","未処理","","","","","","","","0","K0894 1.3H","K0894","1.3H","7008-31020","0","","踏切遮断機修理","2008/07/26","7008/07/31","1","","0","","0","","0","","0","14","G","","","","","581","K川﨑 博紀(52919)","1793","U大久保 友子(kes-ookubo)","","107","信・品)機械","","","0","0","0","0","0","0","0","0","0","0","0","0","","","","","","226044","0","","-","-","455",
"3345","使用しない","京三エンジニアリングサービス株式","","202208007","未処理","","","","","","","","0","K0894 1.3H","K0894","1.3H","7008-31020","0","","踏切遮断機修理","2008/07/26","7008/07/31","1","","0","","0","","0","","0","14","G","","","","","685","K帯津 貴子(55466)","1793","U大久保 友子(kes-ookubo)","","107","信・品)機械","","","0","0","0","0","0","0","0","0","0","0","0","0","","","","","","226044","0","","-","-","455",
"3200","使用する","日立金属商事株式会社","日立電線","223207080","差戻し","","二芯シールド線","S-IREV-SW2X0.3 キイロ(シロ-クロ)","導種_より線_太_AWG22(0.3sq)_被材_IR_PE(80)_シールド__対_1組_全_2本_規_不明_用_不明","","","9320003801","0","","","","8003-31850","2","","副都心線ホーム柵システム 東新宿駅情報伝送装置","2014/03/06","2104/05/20","240","","0","","0","","0","","0","4","P","","","","","1624","K原 智史(67658)","559","K古舘 宏明(52061)","445D1","479","信・製)工程管理","","","97.8","0","0","0","0","0","0","0","0","0","0","0","","","","","","440420","0","445D1
日立電線商事株式会社
223600529 8004-27640 ","-","K飯野 将史(69708)","445",
"3102","使用する","東京電線工業株式会社","東京電線工業","223207094","差戻し","","ATC用ツイスト線","ATC-PV-50/0.18(1.25SQ)","導種_より線_太_AWG16(1.25sq)_被材_不明_対_1組_全_2本_規_不明_用_ATC用_シロ-クロ (100Mタンイ)__シロ-クロ (100Mタンイ)","シ NO.18820","","9320504407","0","","","","8003-31850","2","","副都心線ホーム柵システム 東新宿駅情報伝送装置","2014/03/06","2104/05/20","30","","0","","0","","0","","0","4","P","","","","","1624","K原 智史(67658)","559","K古舘 宏明(52061)","445D1","479","信・製)工程管理","","","60","0","0","0","0","0","0","0","0","0","0","0","","","","","","440420","0","445D1
東京電線工業株式会社
223600533 8004-27640 ","-","K飯野 将史(69708)","445",
"2729","使用する","株式会社ウエノ","サンワサプライ","223642628","完納:","H14040015605","シリアルATA電源アダプタ","TK-PWSAD","","","","C090731131","0","","","","8002-44270","8","","マカオLRT【予備品】","2014/04/15","2914/06/18","2","2014/04/15","2","2014/06/18","2","2014/06/18","2","2014/06/19","0","4","P","","","","","1319","K鈴木 幸雄(52951)","3005","K三好 洸聖(73406)","445B","479","信・製)工程管理","2014/06/18","Abcdefgh","310","0","0","310","620","-75","0","0","0","0","0","0","1-460","","","","","404843","0","","-","K成清 正(58379)","445",
"9028","使用しない","株式会社戸塚電子工業","(株)戸塚電子工業","232267909","完納:","H17020012582","OS-03C3-QR","","","","WR10136CA410B","C110818500","0","","","","5006-78040","2","","TML様向け3.2MHz-8.5kW ジェネレータ","2017/02/16","2027/02/20","1","2017/02/16","1","2017/04/21","1","2017/04/21","1","","0","4","P","","","","","718","K岡村 一隆(56245)","797","K牧野 久(58159)","8","231","PE・生)生産管理","","納品済み同一製番のMCU-VTF改造に使用
","4,520","0","0","4,520","4,520","0","0","0","0","0","0","0","6-630","","","","","536883","0","","-","-","701",';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);