re = /^data:([^;]+);([^,]+),(.*)$/m
str = 'data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAUAAAAFCAYAAACNbyblAAAAHElEQVQI12P4//8/w38GIAXDIBKE0DHxgljNBAAO9TXL0Y4OHwAAAABJRU5ErkJggg=='
# Print the match result
str.scan(re) do |match|
puts match.to_s
end