$re = '/^((\d)\2)(?!\1)((\d)\4)/m';
$str = '3345654865
3344654865
123456
3333654865';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);