package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\d+(?:\.\d*)|\.\d+)(*SKIP)(*FAIL)|\b(?:\d[ -]*?){5,10}\b`)
var str = `12.123456 = no match
Hello John 124567 = match
12345667 = match`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}