re = /\[([^][|]+)\|?([^][|]+)?\|?([^][|]+)?\|?([^][|]+)?\|?([^][|]+)?\|?([^][|]+)?\|?([^][|]+)?\|?([^][|]+)?\|?([^][|]+)?\|?([^][|]+)?]/
str = 'some text here [baz] and here [you|him|her|foo|bar|baz|foo|option|test] and even here [another].'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end