import Foundation
let pattern = #"(\w+\s+)(-)(\s+\w+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #" I took the pill - I realized only after I went off it how it affected my eating habits - I put on weight - around 10 lbs - in the 2.5 months on it - no control and syndrome - this was counterproductive !"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\. \3 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)