$re = '/nationality([^|]+)(;)/';
$str = 'nationality china; asldfkml';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);