#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mix)(?=^[0-9][+-][0-9]+\.[0-9]{2}$)(?:[0-9]+(?:(-)|\+))0+(?!\.)"
Local $sString = "1-000000.02" & @CRLF & _
"1-000000.00" & @CRLF & _
"1+000025.48" & @CRLF & _
"1-000025.47" & @CRLF & _
"1-000000.00" & @CRLF & _
"1+000000.00" & @CRLF & _
"1+000025.46"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)