$re = '/(?<!\d)([1-9]|1[0-9]|2[0-8])(?!\d)/';
$str = 'foo1bar
foo28bar
foo124bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);