$re = '/(import \{ )?((\w+)[, ]+)(?=.*?(\} from \'(.*)\'))/m';
$str = 'import { Grid, Heading, Button } from \'component-library\'
import { Grid, Heading } from \'component-library\'
import { Grid } from \'component-library\'
import { Grid, Heading, Button, Last } from \'component-library\'
import { Grid, Heading, Button } from \'DIFFERENT-library\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);