$re = '/^(?![\w\/]*\/(\w+)\/([\w-]+)\/([\d.]+)\/\2-\3(-\w+)?\.(\w+)).*$/m';
$str = 'com/foo/bar/1.2.3/bar-1.2.3.jar
com/foo/bar/1.2.3/bar-1.2.3.pom
com/foo/blah/1.2.3/blah-1.2.3.jar
com/foo/blah/1.2.3/blah-1.2.3.pom
com/foo/blah/1.2.3/blah-1.2.3-javadocs.jar
com/foo/blah/1.2.3/blah-1.2.3-sources.jar
com/foo/myapp/user-management/1.2.3/user-management-1.2.3.jar
com/foo/bar/1.2.3/blah.jar
blah/1.zip
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);