re = /(?<=[;\s\b]|^)from:(\w+\.\w+)/
str = 'from:website.com;from:website1.com;lfrom:website2.com;var2:343423; lfrom:website1.com;var1:4234234;from:website2.com from:website1.com;_from:website2.com;lfrom:website2.com;var1:43523;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end