using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"prefix(.*)((\/(suffix)?)|$)";
string input = @"prefix/s/o/m/e/t/h/i/n/g/suffix
prefix/s/o/m/e/t/h/i/n/g/
prefix/s/o/m/e/t/h/i/n/g";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}