$re = '/^(?:(?!directory).)*?[\/\?]/';
$str = 'http://localhost:8081/uaeshipping2019/directory/uts-dubai-123456
http://localhost:8081/uaeshipping2019/uts-dubai-123456
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);