$re = '/\B(?=(\d{3})+\b)/m';
$str = '312345678.543543543';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);