#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?:\\u[\da-fA-F]{4}){2})"
Local $sString = "Hi, Jax\ud83d\ude1b\ud83d\ude44! can we go for a coffee?" & @CRLF & _
"Now, the emoji are in UTF16(I think). I need to extract the '\ud83d\ude1b\ud83d\ude44' and give a space between each pair, something like this." & @CRLF & _
"" & @CRLF & _
"Hi, Jax\ud83d\ude1b \ud83d\ude44! can we go for a coffee?" & @CRLF & _
"How can I achieve this in PHP?" & @CRLF & _
"" & @CRLF & _
"More Examples as I would need:-" & @CRLF & _
"" & @CRLF & _
"Hi, Jax\ud83d\ude1b \ud83d\ude44! can we go for\ud83d\ude1b \ud83d\ude44 a coffee?" & @CRLF & _
"So What needed to be done:-" & @CRLF & _
"" & @CRLF & _
"User may or may not leave any space after any normal word and just type a emoji. I mean, Jax\ud83d\ude1b and Jax \ud83d\ude1b."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")