$re = '/Subject :\s*([^*]*(?:\*(?!\*{3}end of input\*{4})[^*]*)*)/';
$str = 'Subject :
So for example, one field can span any number of lines and then there will be a message similar to
****end of input****
It will match anything after the colon until it hits a new line character. This works for almost all of the fields I need to scrape. One however, is a bit more trouble. One of them, the last one I need to scrape (not shown above) will span multiple lines. There\'s no way to predict how long it will be, but instead I have another predefined piece of text I can use to determine where to stop capturing.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);