using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Subject :\s*([\s\S]*?)(?=\*{4}end of input\*{4})";
string input = @"Subject :
So for example, one field can span any number of lines and then there will be a message similar to
****end of input****
It will match anything after the colon until it hits a new line character. This works for almost all of the fields I need to scrape. One however, is a bit more trouble. One of them, the last one I need to scrape (not shown above) will span multiple lines. There's no way to predict how long it will be, but instead I have another predefined piece of text I can use to determine where to stop capturing.";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}