$re = '/\b(?!olo)\w*olo\w*\b(?<!olo)/m';
$str = 'Lorem ipsum dolorolo at sit amet, dolore dolor dolore olore';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);