use strict;
my $str = '_jsuid=1540521894; new=verified; __insp_slim=1441894084306; __insp_wid=1141935839; __insp_nv=true; __insp_ref=d; __insp_targlpu=http%3A%2F%2Flocalhost%2F; __insp_norec_sess=true; aff_tag=55b88a; aff_from=; aff_time=1441896839; gsScrollPos=; _gat=1; _ga=GA1.1.1421736560.1435009203';
my $regex = qr/gsScrollPos=(.*?);|gsScrollPos=(.*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}