$re = '/(?!$)(((?!\s*\/\/|\s*\band\b).)*)\s*(?:\/\/|and|$)\s*/i';
$str = 't/xt1.//text2,and landslide/ andy // text3- and text4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);