$re = '/([a-z]? \d)|([a-z] \d?)/m';
$str = '"a 5"
"b 9"
" 8"
"b "
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);