$re = '/1(?>(?R))*2/m';
$str = '111222222 112222 1111222';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);